Topo Grabber Help

© 2010 Fountain Computer Products

All rights reserved. No parts of this work may be reproduced in any form or by any means - graphic, electronic, or mechanical, including photocopying, recording, taping, or information storage and retrieval systems - without the written permission of the publisher.

Products that are referred to in this document may be either trademarks and/or registered trademarks of the respective owners. The publisher and the author make no claim to these trademarks.

While every precaution has been taken in the preparation of this document, the publisher and the author assume no responsibility for errors or omissions, or for damages resulting from the use of information contained in this document or from the use of programs and source code that may accompany it. In no event shall the publisher and the author be liable for any loss of profit or any other commercial damage caused or alleged to have been caused directly or indirectly by this document.

Printed: July 2010
# Table of Contents

Foreword 0  

Part I Contents 5  

Part II Overview 7  

Part III Step-by-Step Procedure 9  

Part IV Topo-Grabber Pages 12  

1 Index Page 12  

2 Image Loader Page 12  

   Image Display 13  

   Loader Controls 14  

   Tools Bars and Status Bars 15  

   Measure Tool 17  

Part V Tools and Options 20  

1 Saving Images 20  

2 Printing Maps 20  

3 Google Earth Export 21  

4 Saving Positions 23  

5 Tile Positions 23  

6 Saving Defaults 24  

Part VI Geographic Coordinates 26  

Part VII Map Spacing 30  

Part VIII Technical Details 32  

Index 0
Part I
1 Contents

Topo-Grabber is a program that allows you to download and print USGS topographic maps for any part of the United States including Alaska and Hawaii. You can use it to find and print topographic maps of any size, resolution or location in the United States. Topo-Grabber can also provides black and white aerial photos for all the the United States and high resolution color photos for selected urban areas. Here index of the topics:

Overview. Tools and Options.
Step-by-Step Procedures Geographic Coordinates
Topo-Grabber Pages. Map Spacing
Index Page Technical Details
Image Loader Page
Part II
2 Overview

The Topo-Grabber works by downloading Topographic Maps from the Microsoft MSR web site. The web site contains a huge data base of all the USGS topographical maps for the United States.

Unlike other software and web pages, Topo-Grabber allows you to load topographic maps of any size. As a result you can generate topographic maps that cover very large areas. In addition, you can create topographic maps that can be overlaid over terrain using programs like Google Earth.

Here are some of the features of the program:

1. Simple Mouse Zoom and Positioning. The program allows you to drag the map into position by dragging it with the mouse. You can center and zoom on a location in the map by double clicking.

2. Resolution. The maps can be the same resolution as the 30-minute, 15-minute and 7.5 minute quadrangles that are available from the USGS.

3. Map Size. The maps can be any size ranging from a single 8.5 x 11 sheet to maps covering large pieces of paper or dozens of individual sheets.

4. Printing. The maps can be printed on any color printer. The prints can be single sheet or multi-sheet allowing very large maps to be pieced together.

5. Google Earth Overlays. The Topographic maps can be exported as Google Earth KMZ files to be overlain on the Google Earth Globe. This can be very useful because Google Earth doesn't always have all the terrain details, surface features and place names that a USGS topographic maps does.

6. Move To Google Earth Location. If you find a location in your map that you want to examine in more detail, you can press a button and Topo Grabber will automatically open Google Earth and zoom on the same location you are viewing in the topographic map.

7. Measurement Tools. You can measure distances, angles and area on topographic maps and aerial photos. For example, you could measure the area of a reservoir or a city with the measurement tools.
Part III
3 Step-by-Step Procedure

Using the Topo-Grabber is relatively simple and intuitive. Here is a set of step-by-step procedures to walk you through the process of viewing a topographic map for an area.

1. Locate General Map Location. Using the Index Maps on the Index Map Page, locate the general location of the map you wish to view.

   Double click on the map at the location of the map you want to view. This will take you to the Image Loader Page and the specified map will begin downloading.

2. Zoom and Pan. At this point, you probably won't be precisely centered on your target location. You can center the map on the correct location by dragging the Images with the mouse.

   You can also center on a location by double clicking on a location. If the “Auto-Zoom” option is enabled, each time you double click, the program will center and zoom on the target location.

3. Resolution. You set the exact resolution in Meters Per Pixel using the tool panel on the left. These resolutions also correspond to original topographic map sizes like 30-minute, 15-minute and 7.5-minute.

4. Map Size. The maps consist of tiled images where each tile is 200 x 200 pixels. The default size is 3 by 3 tiles which gives a pixel size of 600x600. You can increase or decrease the size of the map changing the number of tiles along the X and Y axis.
5. Printing. There are a number of ways to export the topographic maps or aerial photographs from Topo-grabber. Most people will want to print a copy of the map.

To do this, select the "File" then "Print Map Image" options from the menu bar. This will display the Print Options window. The map can be printed on a single page or tiled across several pages.
4 **Topo-Grabber Pages**

Topo-Grabber is divided into two main pages, the Index Page and Image Loader Page. You can select either one by clicking on the Tabs at the top of the Topo-Grapher window.

Here is a detailed description of each page:

Index Page
Image Loader Page

4.1 **Index Page**

The Index Page shows three maps, one of the lower 48 states, one of Alaska and one of Hawaii. The maps allow you to select a part of the country from which to load maps.

**Selecting A Map.** Double clicking on any location on any map will cause the program to switch to the "Image Loader Page" and load the corresponding topographic map for the area under the cursor.

**Cursor Position.** If you move the mouse cursor across one of the maps, the Longitude, Latitude and UTM coordinates will be displayed on the status bar at the bottom of the page. This allows you to zero in on specific locations.

The Index Page also shows the position of topographic map as you move around in the Image Loader Page. This allows you to see an overview of your position even after you have navigated a long way from your original location..

4.2 **Image Loader Page**

The Image Loader Page controls downloading and display of maps.
The page is divided into several sections. Here is a detailed description of each section:

- **Image Display**
- **Loader Controls**
- **Tool/Status Bars**
- **Measure Tool**

### 4.2.1 Image Display

The Image Display shows the current topographic map or aerial photograph.
You can directly manipulate the image using common mouse commands:

**Dragging.** If you move the mouse cursor to the middle of the image, hold down the left mouse button and move the cursor, the image will move with the mouse dragging it to a new position. As you do this, new parts of the map will be exposed. Since they may not be downloaded yet, as soon as you release the mouse button, the program will download any missing tiles and fill in the blank areas.

**Centering/Zooming.** If you double click with the left mouse button on any location in the image, the program will automatically center the image on that point. If the "Zoom-In Button" option is down, double clicking will also Zoom in one step. Likewise, if the "Zoom-Out Button" is down, it will zoom out one step.

Overview Position. As you navigate and explore the maps, the position of the map is updated on the Index Page. This allows you to see an overview of your position even after you have move a long way from your original position.

### 4.2.2 Loader Controls

The Loader Controls appear to the left of the image on the Image Loader Page. These options control various aspects of the way topographic maps and aerial photographs are displayed.
Theme. This option allows you to choose to display topographic maps, aerial photos or color aerial photos. All of the US, Alaska and Hawaii are covered by Topographic maps. Most places are covered by black and white aerial photos and a few cities are covered by high-resolution color aerial photos.

Scale Meter/Per Pixel. All the topographic maps and aerial photos can be displayed at 12 different scales specified in Meters/Pixel. To zoom in, you would choose a smaller scale. For example, switching from 128 to 64, would make all the details in the map twice as big. Some of these scales correspond to standard USGS topographic maps, such as 30, 15 and 7.5 minute quadrangles.

Double Click Zoom. Double Clicking on the Image allows you to zoom in or out one step. It will also center on the spot where you clicked. If the Zoom-In Button is down, the program zooms in by one resolution step. If the Zoom Out Button is down, the program zooms out one step. If neither button is down, the program just centers on the point where you double clicked.

Image Size. Each map is made up of a number of 200 pixel square tiles. The default map size is 3 tiles horizontally and 3 tiles vertically, which gives a map size of 600 x 600 pixels. You can create larger maps by changing the number of tiles in each direction. Very large maps can be created this way, although it is best to keep the map small until you've located the target areas. Larger maps take longer to load and can be slow to manipulate.

Connection Speed. This setting allows you to optimize the operation of the program based on the type of internet connection you have. If you have a high speed connection such as DSL, Cable Modem or Satellite connection, you should select the "Broadband" option. If you have slower connection such as a phone modem, you should use the "Dialup" option. (See the Technical Details section for further information.)

You save can save this setting so the program always runs with this item set the way you want using the Save Defaults command.

4.2.3 Tools Bars and Status Bars

Topo Grabber has several tool bars and status bars that allow you to control the operations of the program and view the status of various operations.

I. Top Tool Bar. The Top Tool Bar appears along the top of the Image Loader page and it is used to manually load or manipulate the map.
Load Button. Pressing the Load Button causes the program to fetch the map corresponding coordinates just to the right of the button. (described below.)

UTM Position. This option allows you to display a map at a specific location. The location is specified in UTM coordinates for the lower left corner of the map. After you have entered the coordinates, press the "Load Button" (described above) to start loading the map.

Abort Button. The Abort Button cancels any map-loading operations that are taking place. This can be useful when the internet is slow and the map does not load quickly. (Note it may take 20 or 30 seconds for the complete map to load. See the Technical Details for more information.)

Zone Buttons. The topographic maps are organized around UTM zones. UTM zones get narrower as you move toward the north. As a consequence, there is an empty space or a gap between each zone in the maps. As you zoom in on a map, the gaps get wider. The Zone Buttons allow you to skip from the edge of one zone to the edge of the next zone. That saves a lot of time when you are working on the edge of a zone. See the Map Spacing section for more information.

Pan Buttons. The pan buttons allow you to move the map one tile to the north, south, east and west directions. It is usually easier to move the map by dragging the image, but these buttons can be useful when you don't have a good mouse or you want to move in large steps.

Diagonal Buttons. Pressing the diagonal buttons allow you to move the map one tile diagonally northeast, southeast, northwest and southwest.

Google Earth Button. Pressing this button shows the current area in Google Earth. It does not overlay the map in Google Earth, it just shows the location. To overlay a topographic map or aerial photo from Topo Grabber, see the Google Earth Export option.

Align Button. Pressing this button moves the map to an even tile boundary. This can be useful if you want to align the map to a precise geographic boundary.

II. Image Tool Bar. The Image Tool bar is just above the Image Display and controls certain aspects of the map image.
**Show Grid.** When the Show Grid box is checked, the map will show a grid with lines along the edges of the image tiles.

**Magnifier.** The magnifier allows you to magnify or shrink the map image. If you slide the control to the right, the image will be magnified. If you slide it to the left, it will shrink. The magnification can be from 0.3 to 4.5 times.

Magnification is different from map scale. Map scale is the basic resolution of the map or aerial photo. The magnifier allows you to increase the or decrease the magnification beyond the basic scale. For example, the highest resolution possible on some aerial photos is only 1 meter per pixel. With the magnifier, you can take the resolution much further to 0.25 meter per pixel.

**Reset Magnifier Button.** The Reset Button sets the magnification back to 1 so the map is displayed at its normal size and resolution.

**III. Image Status Bar.** This status bar displays the location of the cursor in Longitude/Latitude and UTM coordinates. Both decimal degrees and degrees-minutes-second are displayed.

| Long/Lat: 106.3169 38.6700 | -106°19'00" 38°40'11" | UTM: 385,440 4,280,976 | 13 |

**IV. Main Status Bar.** This status bar displays information about the map loading process:

| Progress Bar: 100% | Retries/Lost: 0/0 | Cache Hits: 25 | Load Time: 0.011 Sec. |

**Progress Bar.** The progress bar shows the progress in loading a particular map image.

**Retries/Lost.** If a portion of the image (a tile) doesn't load within a certain period of time, the program repeats the request. The number of attempts to load the image is displayed under the "Retries" section. If you the image is not loaded after several retries, the program gives up and marks the tile as "Lost." The number of lost tiles is displayed under the "Lost" section.

**Cache Hits.** The program retains recently loaded Tiles in a cache. If an tile can be found it the cache, it doesn't have to be reloaded and so the map loads much faster. The Cache Hits item shows the number of tiles that were found in the cache. The more tiles found in the cache, the faster the image loads.

**Load Time.** This item displays the time it takes to load and display the current map.

**4.2.4 Measure Tool**

The Measure Tool allows you measure distances between two points on the map. It also allows you measure the distance along curving path such as a road, trail or highway. Finally, it allows you to measure the area of any object on an aerial photograph or map such as a parking lot, a lake, a property or a town.

To Access the Measure Tool, click on the "Measure" tab on the Image Loader Pager
When the Measure Page is visible, you can click on the map and draw lines. Each time you click on the page, the program places a dot and draws a line from the last dot. In this way, you can draw a line along things like trails and roads in the map. The more dots, the more smoothly the line will follow the trail.

You can reposition any dot by clicking on it and dragging it to a new position. If you right-click anywhere with the mouse, the last dot will be deleted.

The Measure Page displays information about the line you have created. Here is a description of each item:

**Length.** The Length display shows the total length of all the lines segments that make your line. The units for this length can be any common measurement such as meters, feet or miles.

**Area.** This shows the area of the line segment if the first and last points were connected together. This is useful for measuring the size of plots of land and natural features such as parking lots, or lakes.

**Azimuth.** This item display compass direction in degrees of between the next-to-the-last point and the last point. This is useful for finding bearings between two locations.

**Length Units.** These options allow you to chose what units will be used to display the line length.

**Area Units.** These options allow you to chose what units will be used to display the line Area.

**Reset Measurements.** Pressing this button deletes all the dots and lines.
Part V
5 Tools and Options

Topo Grabber has several special tools and options. Here are detailed descriptions of each option:

- Saving Map Images
- Printing Maps
- Google Earth Export
- Saving Positions
- Tile Positions
- Saving Defaults

5.1 Saving Images

The map image can be saved as any common bitmap type. This is useful for loading them into web pages, documents or editing them with a graphics editor.

To export the current image, select the "File -> Save Map Image" option from the menu bar. You have a choice of saving the file as a bmp, gif, jpg, png, tga, tif, emf and wmf. Simply set the extension to match the format you want. You can also select the extension from the drop down list.

5.2 Printing Maps

You can print maps as single sheets or as multi-page sequences. To print the currently display map, select the "File -> Print Map Image" option from the menu bar. You will be presented with Print Layout window:

The Print Layout window allows you to control the way the map is printed. Here is a detailed description of each section:

I. Print Preview. The Print Preview sections show you exactly how the maps will be laid out on each page of paper. As you make adjustment, the pages will change so you can see exactly how the map will appear.

II. Size. The Size displays shows the width and height in pixels of the base image.

III. Scale. This is the scale of the map in Feet per Inch in the final print out.
IV. Print Method. The Print Method controls the way the base maps placed on the paper. There are three options:

A. Actual Size. With this method, the base image is placed on the paper pixel-for-pixel the same size as the base image. Since printers have much higher resolutions than a computer monitor, the image will generally seem smaller than it appears on the screen. If the image is larger than one page, the image overlap onto additional pages.

B. Fit To Page. With this method, the base image stretched or shrunk to fit on one page of paper.

C. Manual Scale. With this method, you can manually set the scale of the image however you want using the Scale Control described below.

V. Scale Control. The Scale control allows you to set the scale when you are in the Manual Scale Mode described above. If the scale is set to one, the image is printed its actual size, like option "A" described above. Increasing or decreasing the scale, causes the image to get bigger or smaller. If the image is bigger than one page, it will overlap on to additional pages.

VI. Print Button. Pressing the Print button displays the normal Windows Print dialog which allows you to configure your printer and print the map image.

VII. Print Setup. Pressing the Print Setup button displays the standard Window Print-Setup dialog which allows you to configure your printer. For example, you can change the printer from portrait to landscape mode. Any change you make will be reflected in the Print Preview display as soon you close the Setup Dialog.

5.3 Google Earth Export

One of the uses of Topo Grabber is to overlay topographic maps on Google Earth.
While Google Earth provides high resolution aerial photograph in most places, it lacks detail about features such as trails, forest boundaries, section boundaries, springs, streams, mines, towns, place names, etc.

As a result, Topo Grabber allows you to overlay Google Earth images with any topographic map or aerial photograph. This is accomplished using "KMZ" files, which Google Earth and other programs can read.

Exporting KMZ Files. To Export a map to Google Earth, select the "File -> Export &KML/KMZ file" option from the menu bar.

After the file has been saved, you can double click on the file, and (if you have Google Earth installed, ) the program will automatically load the file and zoom in on the area of the topographic map.

Note. There are a few areas where the topographic maps are not properly aligned to geographic coordinates. For example, some 15-minutes maps near the Grand Teton in Wyoming are not properly aligned to geographic coordinates. This means that when you overlay the maps in Google Earth, they will be off from their proper locations. You can fix the problem by manually aligning the maps in Google Earth. Just select the overlay map in Google Earth's left-hand panel, then right click and select the "Properties" option. This will bring up a dialog box that will allow you drag or rotate the image to its proper position. Refer to the Google Earth Help for more detailed information.
5.4 Saving Positions

You can save the position and scale of any map so you can recall it later. To do this, select the "Options -> Save Position" item from the menu bar.

This will display the Save Positions dialog. The dialog is divided into two sections the Save Positions List and the Tool Bar.

Positions List. The Saved Position List display a list of all the saved positions that you have accumulated. The positions are automatically saved so they remain in the list until you delete them.

The Description column is editable. You can click on any cell or hit F2 and change the description to one of your own choosing.

Tool Bar. The tool bar allows you to perform various action on the Position List. Here is a detailed description of the operation of each button.

Insert Button. Pressing this button will cause the currently displayed map-location to be inserted into the list. The program automatically creates a description based on the map grid position. You can change the description by clicking on the cell and hitting F2.

Fetch Button. Pressing this button will cause the currently selected position to be fetched and displayed. Double clicking on a row in the Position List will do the same thing.

Move Up/Down Buttons. These buttons are used to move a saved position up or down in the list. Pressing the Up/Down button moves the selected position up or down one row. This allows you to put the most frequently used position near the top of the list where they will be easily accessible.

Delete Button. Pressing this button deletes the selected position. Deleted positions cannot be restored without relocating and re-inserting the position. For this reason, the program warns you before deleting a position.

5.5 Tile Positions

The Tile Position Dialog allows you to see and adjust the map by tile position and offset. It is reached by selecting the "Options -> Tile Position" item from the menu bar. It is mostly used for program debugging and curiosity. The average user will find it much easier to navigate using the other map-
selection tools in the program.

5.6 Saving Defaults

You can save the current configuration of the program so the next time it runs, you'll have the same settings. This saves you the hassle of changing them every time you start the program.

To save the current settings, select the "Options -> Save Defaults" item from the menu bar. The next time you run the program, all the settings will match the ones you just saved.
Part VI
6 Geographic Coordinates

Topo Grabber uses various geographic coordinate system to locate and display maps. Cartographers use these to locate landmarks and terrain on the surface of the earth. For this reason, it is useful to understand geographic coordinates and how they work. Here is a short tutorial:

Longitude And Latitude. One of the standard systems for locating a point on the face of the earth is called longitude and latitude. The system measures the location of a point on the surface of the earth in degrees. Longitude measures the number of degrees east or west of a north/south line (meridian) that runs through Greenwich, England. Latitude measures the number of degrees north or south of the equator.

Longitude and Latitude are usually displayed in Degrees, Minutes and Seconds. It is often displayed on maps with single and double quotes used to specify the minutes and seconds part:

106º 37' 30"

Longitude and Latitude can also be displayed as decimal degrees. For example:

106º 37' 30" = 106.625

Locations west of the England have negative longitudes and locations east of England have positive longitudes. Locations north of the equator have positive latitudes and locations south of the equator have negative latitudes.

Geodetic Datum. One of the problems with any measurement on the surface of the earth is the fact that the earth is not a perfect sphere. In fact, the centrifugal force generated by the rotation of the Earth causes it to bulge at the Equator and flatten at the poles. In addition, the Earth has odd bulges and depression over various parts of the surface. These irregularities can make measurements difficult and inaccurate.

As a result, surveyors have developed complex mathematical models that approximate the shape of the earth. These models are used to compensate for the Earth’s odd shape.

Over the years, surveyors have gradually refined these models to make them more and more accurate. Also, some of them are specially refined for particular countries or regions. The result is that there are dozens of different constants that have been used to make maps and surveys. For this reason, different maps
done at different times or in different parts of the world use different models.

These mathematical models consists of numeric constants called Geodetic Datums and most maps specify which datum was used to create a map. Each Datum has a name that is used to identify a specific set of constants. For example, in the United States, most maps have been created using "WGS 84," "North American 1927" or "North American 1983". Topo Grabber uses WGS 84. for all its measurements.

Universal Transverse Mercator (UTM). While Longitude and Latitude are universally used for navigation, they are awkward for local mapping tasks like laying out roads, planning cities or buildings. There are several problems with Longitude/Latitude in this situation. First, while the earth is a sphere, most maps are printed on flat pieces of paper. When you project longitude and latitude lines on a flat piece of paper, it inevitably results in distortion. For example, in some projection systems, the lines will be curved. Trying to adjust a local map to curved lines can be very awkward and confusing. Second, since the longitude/latitude system uses degrees as the unit of measure, it is hard to calculate the distance between two points.

UTM is a more useful system for locating caves because it uses a square grid of Cartesian coordinates. In order to maintain the square grid on a curved earth, UTM divides the earth into narrow zones. Because the zones are narrow, the distortions and other problems are reduced.

The Standard UTM system divides the earth up into 60 zones, each one six degrees wide, running north and south at right angles to the equator. Each zone is about 415 miles (668 kilometers) wide at the equator. Each zone is narrow enough that the earth’s curvature has a minimal effect and a square grid can be used inside the zone. This means you don’t have to worry about mapping against curved lines.

Each zone is numbered. Zones in the Northern Hemisphere are positive and zones in the Southern Hemisphere are negative.
**UTM Coordinates.** UTM coordinates are the measured distance north from the equator and east from the left edge of the zone. That means that no coordinates are negative. With these two numbers and a zone number, you can specify the location of any point on earth. UTM coordinates are usually specified in meters, but occasionally they may be converted to feet. Because, of the curvature of the earth, the zones narrow at the north and south ends.

**Convergence.** Because UTM places a square grid on top of a curved earth, the longitude lines will appear to curve underneath the grid. For this reason, the UTM grid lines don’t always point directly at the North Pole. "Convergence" is the amount the UTM grid is misaligned with the earth's North Pole. If a cartographer wants a map to be precisely aligned with UTM grid and not True North, they must rotate the map to compensate for the convergence.
Part VII
Map Spacing

The maps and aerial photographs used by Topo Grabber use Universal Transverse Mercator (UTM) as their geographic coordinate system. UTM coordinates divide the world up into six-degree wide zones. Because of the shape of the earth, those zones get narrower as you go north. As you get near the north pole, the zones get very narrow.

The topographic maps Topo Grabber loads from the internet are also organized around UTM zones.

At the equator, the maps would be right next to each other, but as you move north, there is a gap that get bigger, the further north you go.

The map to the right, shows two zones in northern Alaska. As you can see, the maps are narrow and there is big white space between them. As you zoom in on the maps, the gap zones becomes bigger and bigger and it is more difficult to move between zones by dragging the map.

For this reason, Topo Grabber has two Zone Buttons that allow you to skip from the edge of one zone to the edge of the next zone. That saves a lot of time when you are working on the edge of a zone.
Part VIII
8 Technical Details

How Topo Grabber Works. Topo Grabber loads a map as a series of 200 x 200 pixel images. These images are tiled into a full map. The image to the right illustrates how the maps are assembled. Each tile corresponds to a specific geographic location. (Although there is no advantage to doing this, you can observe and manipulate the tile number using the "Tile Positions Dialog.")

The size of the map is control by the number of tiles that are loaded and assembled into an image. The more tiles in the image, the larger the map. You can control the size of the map by setting the number of tiles in the map. Since the tiles are 200 x 200 pixels, the maps can only be multiples of these dimensions. For example, a map can be 400 x 800 pixels, but not 640 x 480.

The Downloading Process. Topo Grabber gets the map images and aerial photographs from the Microsoft MSR Maps service. When you go to load a map, the program calculates which tiles are needed to display the map and begins making requests requests from the server. As the images are received, they are displayed in their proper position and the map is gradually assembled.

Retries. If the server fails to respond to a request for a tile, the program will retry up to four times. If the server still fails to respond, the program will give up and leave the tile blank. The number of retries and number of tiles lost is displayed in the status bar. Lost tiles are usually the result of heavy internet traffic. Lost tiles will usually load by pressing the Load Button.

Image Cache. When you are working in the a specific area, the same tiles will be requested repeatedly as you move around. For this reason, the program keeps a cache of the last 100 images that were loaded. Before loading any tiles from the internet, the program checks to see if any of the tiles are in the cache. If they are, the program can display them instantly, saving lots of download time.

Threads. If you have a broadband connection, the program can speed the up the loading process by downloading more than one image at a time. The program does this by requesting all the images at once and using a separate "thread" to wait for the image to be received. Since separate threads operate independently of each other, they don't slow the computer down and other tasks can be performed will a thread is waiting. (This is called multi-tasking.) This speeds up the process because while some images are being loaded, others can be displayed. Using multiple threads doesn't work very well for a dialup connection because the phone line is slow. For this reason, you have the option of disabling threads to handle a dialup connection.